Hosted Exchange - Monitoring Email Client Sync Issues
Incident Report for Liquid Web - Services
Resolved
Following extended monitoring, the Hosted Exchange email client connectivity issue is operating as normal and confirmed to be fully resolved.
Posted Mar 15, 2022 - 07:26 CDT
Monitoring
We are monitoring reports of connectivity issues to our Exchange environments via email clients such as Outlook. Symptoms reported were errors upon attempting to sync mail to their email client, or a prompt to re-enter their password.

At this time corrective actions have been made however, monitoring is ongoing. Should issues resume and Hosted Exchange access be needed immediately, all mailboxes can be accessed via the OWA client here https://webmail.emailsrvr.com/.

We apologize for any disruption this may have caused.
Posted Mar 15, 2022 - 05:55 CDT
This incident affected: Business Email.