Internal Support System Outage
Incident Report for Liquid Web - Services
Resolved
This issue has been resolved. Our support systems are functioning properly at this time.
Posted May 07, 2021 - 11:39 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 06, 2021 - 16:29 CDT
Update
We are continuing to investigate this issue.
Posted May 06, 2021 - 16:06 CDT
Investigating
We have detected an issue with our Internal support system. We are working diligently on resolving the issue. We apologize for any inconvenience that this may cause.

If you have any questions or concerns, please contact a member of our support team via live-chat, ticket (support@liquidweb.com), or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted May 06, 2021 - 15:23 CDT
This incident affected: Support Services (Chat Support, Ticket Support, Phone Support) and API, Management Portal.