Liquid Web Portal Degraded
Incident Report for Liquid Web - Services
Resolved
This issue is now resolved.
Posted Dec 15, 2022 - 15:35 EST
Monitoring
A fix has been implemented for the login issues. Our teams are currently monitoring to ensure the login continues functioning as expected.
Posted Dec 15, 2022 - 15:07 EST
Investigating
Our teams are currently investigating an issue causing login failures to our portal. We will update this status post as more information becomes available.

If you have any questions, please contact a member of our support team via ticket or by phone at +1-866-639-2377 (US) or +1-517-322-0434 (international).
Posted Dec 15, 2022 - 14:16 EST