PayPal Payments Degraded
Incident Report for Liquid Web - Services
Resolved
This issue is now resolved. Our teams have confirmed PayPal payments are working as expected.
Posted Oct 20, 2021 - 14:18 EDT
Investigating
We are currently investigating an issue with PayPal payments failing for new orders. Credit Card payments are still functioning as expected at this time.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Oct 20, 2021 - 12:26 EDT