Phone system is down
Incident Report for Liquid Web - Services
Resolved
Our phone system is fully operational. This issue has been resolved.
Posted May 29, 2020 - 22:20 EDT
Investigating
We are currently investing an issue with our phone system. At this time we are unable to receive new phones calls, however we can still be reached via chat (liquidweb.com) or email/ticket (support@liquidweb.com).
Posted May 29, 2020 - 21:55 EDT
This incident affected: Support Services (Phone Support).