PHX Network
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Jan 03, 2020 - 09:32 CST
Investigating
We are currently aware of a network issue in our Phoenix (DC4) data center. This is causing certain clients to experience limited connectivity issues. We have dispatched technicians, and are working to resolve this issue as soon as possible.

We are available to assist with any questions or concerns at (800)-580-4985, (517)-322-0434 (international), or by email at support@liquidweb.com.
Posted Jan 03, 2020 - 08:17 CST
This incident affected: Data Centers (DC4 - PHX).