Cloud Block Storage and Object Storage Degraded
Incident Report for Liquid Web - Services
Resolved
This issue is now resolved.
Posted Oct 28, 2022 - 08:42 CDT
Update
We are continuing to monitor for any further issues while we work to correct any remaining outlier issues that may still be impacting some customers.
Posted Oct 26, 2022 - 09:50 CDT
Update
We are continuing to monitor the situation and are seeing that the performance degradation had been affecting Acronis backups in some cases as well.
Posted Oct 25, 2022 - 03:05 CDT
Monitoring
Our teams are have implemented a fix that is currently still in the process of running. We're seeing traffic shift back normal levels. Traffic may still be impacted, however the issue has been stabilized and we will continue monitor progress.
Posted Oct 25, 2022 - 01:33 CDT
Investigating
Our teams are currently investigating Cloud Block Storage and Object Storage performance issues. We will update this post as more information becomes available.

If you have any questions or concerns, please contact a member of our support team via live-chat, ticket (support@liquidweb.com), or by phone at 1-800-580-4985, 1-517-322-0434 (international).
Posted Oct 24, 2022 - 20:33 CDT