Phone Service Interuption
Incident Report for Liquid Web - Services
Resolved
The issue has been resolved and we apologize for the inconvenience.
Posted Mar 08, 2019 - 12:14 EST
Investigating
It has been reported that customers are having issues using our 1-800 number, however, our (517)322-0434 is working correctly. We’re investigating this issue. If you’re contacting us for phone support please use (517)322-0434.
Posted Mar 08, 2019 - 11:33 EST
This incident affected: Support Services (Phone Support).