Liquidweb.com Down
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved. Liquidweb.com is now functioning as expected.
Posted Sep 30, 2020 - 14:26 EDT
Monitoring
We have mitigated the DDOS attack against Liquidweb.com. We are continuing to monitor the traffic and will update as needed.
Posted Sep 30, 2020 - 12:46 EDT
Investigating
Currently we are looking into issues with Liquidweb.com being down. It appears that this is due a large incomming DDOS to the site. Our teams are currently working on mitigating this attack and the site should be back up shortly. We will continue to monitor the situation and update as more information is gathered.
Posted Sep 30, 2020 - 11:45 EDT
This incident affected: Management Portal.