Blacklisted IPs
Incident Report for Liquid Web - Services
Resolved
This issue has been confirmed to be resolved by our teams.

If you have any questions, please contact a member of our support team via live-chat and ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Feb 24, 2021 - 07:03 CST
Investigating
Teams are currently investigating a report of IP addresses showing on a less commonly used blacklist, and are working to resolve the issue. Some customers have experienced a delay in email delivery as a result. If you experience any issues, please feel free to reach out to our Support Team at 1.855.348.9060 or international at +1.517.322.0434.

We will continue to update this status as more information comes available.
Posted Feb 09, 2021 - 09:48 CST