Managed WordPress and WooCommerce Account Creation
Incident Report for Liquid Web - Services
Resolved
Our engineers have resolved the issue with provisioning. We apologize for any inconvenience this may have caused.
Posted 3 months ago. Jul 30, 2019 - 01:37 CDT
Identified
At this time our team is investigating delays with provisioning new Managed WordPress and Managed WooCommerce accounts. Additional information will be provided as soon as it is available.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted 3 months ago. Jul 29, 2019 - 23:19 CDT
This incident affected: Managed WordPress and Managed WooCommerce.