Premium Business Email - Identities Reset
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Dec 22, 2019 - 07:54 CST
Update
Webmail identities have been restored from a backup.

We encourage affected users to verify settings in the identities section before saving any changes. Users are also encouraged to log out of any current Webmail session to prevent any incorrect identity data from being saved.

Email delivery is not impacted at this time, however replies sent to user20043@nw-demo.mailtrust.com will have been rejected and will need to be resent.

After extended monitoring and verification since the restoration, we have confirmed this issue is fully resolved. We sincerely apologize for the disruption this has caused. If you have any further issues please contact our support team directly.
Posted Dec 22, 2019 - 07:53 CST
Update
Our provider continues working towards a resolution as quickly as possible.

Email delivery is not impacted at this time, however replies sent to the incorrect identity will have been rejected and will need to be resent.

Thank you for your continued patience.
Posted Dec 21, 2019 - 22:30 CST
Identified
Our Email Vendor is currently experiencing an issue where many Premium Business Email accounts have had their "Identities" in Webmail inadvertently renamed to user20043@nw-demo.mailtrust.com. They are working on reverting this change at this time, however, we have no estimated time on when the issue will be fully resolved. This issue is not impacting our Hosted Exchange environment.

If your mailbox has been affected, it is possible to manually reset the mailboxes "Identity" through Webmail through the Settings.

- To find your Email Settings, navigate to the menu icon in the upper-right hand corner of your webmail homepage, next to your email address.

- Select the Settings link from the drop-down menu.
- Select 'Composing Email' then select the 'Identities' tab.
- Select 'Add New Identity' fill out the fields and click save.

Once the new identity has been created make sure to set it as the default identity. You can do this by clicking your new identity and then selecting "Set as Default" to the right of 'Edit' under the Identities tab.

Here is an article which expands on the settings available via Webmail
https://help.liquidweb.com/s/article/Updating-Your-Premium-Business-Email-Webmail-Settings

We sincerely apologize for this disruption and appreciate your patience in the matter. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Dec 21, 2019 - 13:07 CST
This incident affected: Business Email.