Premium Business Email outage
Incident Report for Liquid Web - Services
Resolved
We have received no more reports of issues relating to our Premium Business Email and the incident is now resolved. If you notice any problems please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Feb 10, 2019 - 04:45 EST
Monitoring
Our upstream email provider indicates the issue is now fully resolved. We are monitoring the situation to ensure things remain functioning as intended.
Posted Feb 10, 2019 - 04:02 EST
Update
Our upstream email provider has indicated that the issue should be resolved for most users at this point. If you were previously unable to connect, please try again now. If you are still unable to connect, please reach out to us so we can further troubleshoot the problem.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Feb 10, 2019 - 03:28 EST
Identified
We are currently experiencing an issue with the Premium Business Email service. This is affecting Webmail, POP, IMAP, and SMTP. User may experience errors when attempting to login via any of the mentioned services. The Engineers are currently investigating the cause. More details will be posted as soon as they become available.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Feb 10, 2019 - 03:08 EST
This incident affected: Business Email.