Phone Support Degraded
Incident Report for Liquid Web - Services
Resolved
This issue is now resolved.
Posted Jan 27, 2022 - 13:12 EST
Monitoring
This issue is currently in a monitoring status. Phone calls are functioning as expected at this time.
Posted Jan 27, 2022 - 12:19 EST
Investigating
We are currently investigating an issue with our phone system. We will update this status post as more information becomes available.

If you have any questions, please do not hesitate to contact a member of our support team via live-chat or ticket.
Posted Jan 27, 2022 - 12:15 EST