Intermittent issues with sites behind Cloud Flare
Incident Report for Liquid Web - Services
Resolved
CloudFlare has resolved their status post.
Posted Jul 17, 2020 - 19:06 EDT
Update
CloudFlare has identified the issue and they are implementing a fix.
Posted Jul 17, 2020 - 17:53 EDT
Identified
At this time, Cloudflare is reporting issues with their Network. You can find more information regarding the status here:

https://www.cloudflarestatus.com
https://twitter.com/CloudflareHelp/status/1284240964794511360

We are following the situation closely and will update you as soon as we learn more.
Posted Jul 17, 2020 - 17:50 EDT
Investigating
We are currently experiencing intermittent issues with websites behind CloudFlare resulting in a cannot connect error. Additional information will be provided as soon as it becomes available.
Posted Jul 17, 2020 - 17:36 EDT