Chat System Issues
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted May 06, 2021 - 22:15 EDT
Investigating
We are investigating an issue with our Chat system that is preventing customers from being able to initiate chats. This is an intermittent issue.

We are sorry for this inconvenience and will have this resolved as soon as possible.

If you have any questions, please contact a member of our support team via ticket or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted May 06, 2021 - 14:27 EDT
This incident affected: Support Services (Chat Support).