Premium Business Email Issue
Incident Report for Liquid Web - Services
Resolved
Our email vendor has indicated the Administrative Control Panel is operating as normal. This issue is now resolved.
Posted Nov 01, 2021 - 12:15 EDT
Monitoring
A solution has been put in place and administrators are beginning to see some success using the Administrative Control Panel. Additional updates will be posted as they are available.
Posted Nov 01, 2021 - 11:18 EDT
Investigating
Our email vendor is aware of an issue that is affecting their Administrative Control Panel. Administrators attempting to add, remove, or modify a Hosted Email mailbox may receive an error or continuous loading.

Changes made to Hosted Exchange are not impacted at this time.

They are investigating that issue and we will provide updates when we have them.
Posted Nov 01, 2021 - 11:01 EDT
This incident affected: Business Email.