Limited Support Availability
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Mar 03, 2021 - 09:11 CST
Update
Closing out this issue following extended monitoring.
Posted Mar 03, 2021 - 09:11 CST
Update
We are continuing to monitor for any further issues.
Posted Feb 16, 2021 - 16:51 CST
Monitoring
Due to severe weather conditions around the country, we anticipate limited availability with our Support Team. All Data Centers have generator backup power so there will be no disruptions to websites or servers.

We apologize for any inconvenience which might be experienced. As always, if you have any questions or concerns, please contact a member of our support team via live-chat, ticket (support@liquidweb.com), or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Feb 16, 2021 - 16:26 CST
This incident affected: Support Services (Chat Support, Ticket Support, Phone Support).