Premium Business Email Control Panel Access
Incident Report for Liquid Web - Services
Resolved
The issue with the Premium Business Email Control Panel has been resolved.
Posted Oct 14, 2022 - 04:01 CDT
Investigating
Currently our vendor is reporting that there is a number of users experiencing connectivity issues with the Premium Business Email environment, specifically the Premium Business Control Panel. Users may experience an error when trying to log in. They are currently working toward full restoration at this time. More updates will be provided as they become available.
Posted Oct 14, 2022 - 02:56 CDT
This incident affected: Business Email.