Premium Business Email - Webmail Issues
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Apr 08, 2019 - 14:01 EDT
Monitoring
Our Email Vendor has reported the issues should now be resolved and we were able to confirm as well. We will continue to monitor and update if we have any issues.

If you are still experiencing issues or if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Apr 08, 2019 - 12:36 EDT
Investigating
Our Email Vendor is currently experiencing issues with logging in or slowness in the Webmail interface. We are continuing to work with them to get this resolved.

We will update as we have additional details. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Apr 08, 2019 - 11:23 EDT
This incident affected: Business Email.