Phone System Issue
Incident Report for Liquid Web - Services
Resolved
At this time the connection to the phone system has been resolved. Fully functionality has been restored and issues identified and resolved.
Posted Apr 17, 2019 - 13:04 EDT
Monitoring
The phone interruption appears to have resolved..but we are continuing to monitor the issues
Posted Apr 17, 2019 - 12:20 EDT
Investigating
Our engineers are investigating an issue interrupting phone access to LW at this time. Support and sales members can still be reached via chat and tickets at this time. As soon as we get more information we will update this post
Posted Apr 17, 2019 - 12:10 EDT