Phone system is down
Incident Report for Liquid Web - Services
Resolved
Our phone system is fully operational. This issue has been resolved.
Posted Dec 05, 2022 - 04:20 CST
Investigating
We are currently investing an issue with our phone system. At this time we are unable to receive new phones calls, however we can still be reached via chat (liquidweb.com) or email/ticket (support@liquidweb.com).
Posted Dec 05, 2022 - 02:41 CST
This incident affected: Support Services (Phone Support).