Business Email Admin Control Panel Issues
Incident Report for Liquid Web - Services
Resolved
The incident has been confirmed to be fully resolved. Thank you for your patience.
Posted Jan 13, 2020 - 22:20 EST
Monitoring
Our vendor has implemented a temporary fix that will allow the functions to no longer fail but may be a slight delay in the action. We will continue to keep you all updated.
Posted Jan 13, 2020 - 14:46 EST
Investigating
Our vendor reported an issue with some functions inside the Admin Control Panel. Examples like provisoning actions like creating mailboxes or changing passwords. We will continue to work with them and stay current on the situation and will update this status page with details as we have them.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (855) 348-9060.
Posted Jan 13, 2020 - 11:06 EST
This incident affected: Business Email.