Business Email Issues
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Dec 11, 2019 - 11:59 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2019 - 11:47 CST
Investigating
Our Email vendor is reporting issues with Webmail and we are working with them to get it resolved. As we have additional info we will provide updates here.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Dec 11, 2019 - 11:26 CST
This incident affected: Business Email.