Degraded Business Email Control Panel
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Mar 14, 2022 - 10:04 EDT
Monitoring
Our email vendor has resolved this issue. We will continue to monitor at this time and add any further updates as necessary.
Posted Mar 14, 2022 - 10:04 EDT
Update
Our email vendor is investigating reports of connectivity issues to our Administrative Control Panel. Administrators may experience errors upon accessing and/or navigating within the Control Panel.

Mail delivery is not impacted at this time.

We will provide further updates as the become available.
Posted Mar 14, 2022 - 10:01 EDT
Investigating
Our team saw an issue with the Business Email Control Panel and are currently investigating
Posted Mar 14, 2022 - 10:01 EDT
This incident affected: Business Email.