Premium Business Email - Mail Issues
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Oct 14, 2019 - 16:11 CDT
Monitoring
Our Email team is in the final stages of remediation for this incident. A solution has been put in place and users are beginning to successfully connect to their mailboxes using Webmail, IMAP, and POP. Additional updates will be posted as they are available.
Posted Oct 14, 2019 - 16:01 CDT
Investigating
We are working with our Email Vendor to investigate and resolve an intermittent issue with the Business Email service with both Webmail and Mail Clients.

Once we have additional information we will update here. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international)
Posted Oct 14, 2019 - 15:39 CDT
This incident affected: Business Email.