Scheduled Facility Maintenance, US-Midwest-1

Scheduled for May 26, 07:00 - 15:00 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted May 23, 2026 - 13:07 EDT

Scheduled

Nexcess Facilities Engineers will be performing scheduled maintenance that will improve the efficiency of cooling systems in our US-Midwest-1 data center in Southfield, Michigan. No impact to customer services or workloads is expected.

Should you need any assistance or have any questions or concerns, you can reach us through the following channels:

Live Chat via the Customer Portal: https://sites-portal.nexcess.com
Email: support@nexcess.net

We appreciate your understanding as we work to improve our services.

System Maintenance Reference: [CC-13468]
Posted May 23, 2026 - 12:51 EDT