Business Email Webmail Issues
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Jan 04, 2021 - 17:13 CST
Identified
Our Email vendor is reporting issues with Webmail and we are working with them to resolve this issue. Our vendor is actively working towards a resolution. A workaround has been identified for users who are receiving errors when trying to update any settings in webmail. If you are experiencing errors please log out of the mailbox from webmail and log back in and check if those changes have been saved.

As we have additional info we will provide updates here.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jan 04, 2021 - 16:02 CST
This incident affected: Business Email.