Premium Business Email - Webmail Access Issues
Incident Report for Liquid Web - Services
Resolved
Our Email Vendor has reported the issues should now be resolved and we were able to confirm as well. We will continue to monitor and update if we have any issues.

If you are still experiencing issues or if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Apr 09, 2019 - 13:07 EDT
Identified
Our Email vendor reached out to us about Webmail issues that some of the customers using Premium Business Email may be experiencing. They are actively working to resolve and we will continue to keep communications with them and will update this post with any additional details. In the meantime, we recommend using email clients or mobile devices as a workaround. Email delivery has not been impacted.

- The inability to access their accounts from the login page
- Latency upon login and while navigating the Webmail interface
- Slow attachment downloads
- Inline images in Webmail not loading

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Apr 09, 2019 - 11:39 EDT
This incident affected: Business Email.