Premium Business Email Issue
Incident Report for Liquid Web - Services
Resolved
Our email vendor has reported the issue is now closed and the hosted email system is operating as normal.
Posted Dec 13, 2021 - 15:36 CST
Investigating
Our Email vendor is reporting issues with Webmail and we are working with them to resolve this issue. As we have additional info we will provide updates here.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Dec 13, 2021 - 14:26 CST