Degraded performance of Liquid Web cart and user portals (my.liquidweb.com and manage.liquidweb.com)
Incident Report for Liquid Web - Services
Resolved
Our team has identified and addressed the issue which was the cause of degraded performance. At this time the Liquid Web Cart and user portals are performing normally.

Thank you for your patience while this issue was being investigated.
Posted Mar 05, 2022 - 16:58 CST
Investigating
We are currently investigating an issue which is causing degraded performance of Liquid Web Cart and our user portals (my.liquidweb.com and manage.liquiweb.com). Our teams are actively working to resolve the issue at this time.

If you have any questions, please do not hesitate to contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Mar 05, 2022 - 16:25 CST
This incident affected: Management Portal.