Premium Business Email control panel
Incident Report for Liquid Web - Services
Resolved
All systems are back up and functional at this time.
Posted Jun 10, 2021 - 10:38 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2021 - 10:30 CDT
Investigating
We have been informed by our vendor that customers are experiencing issues accessing their Premium Business email control panel. We will update this status page when we have more information about it.
Posted Jun 10, 2021 - 10:16 CDT
This incident affected: Business Email.