Live Chat Unavailable
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Sep 04, 2022 - 07:00 EDT
Update
We are continuing to investigate this issue. We will update this status page as further information becomes available.

If you have any questions, please contact a member of our support team via ticket or by phone at +1-866-639-2377 (US) or +1-517-322-0434 (international).
Posted Sep 04, 2022 - 04:43 EDT
Investigating
Currently our Live Chat service is experiencing issues. We are actively working to bring this back up. We are still available to assist with any questions or concerns via email at support@liquidweb.com or by telephone at (800)-580-4985, (517)-322-0434 (international).
Posted Sep 04, 2022 - 02:28 EDT
This incident affected: Support Services (Chat Support).