Managed WordPress and WooCommerce Hosting Account Creation Issues
Incident Report for Liquid Web - Services
Resolved
Our team has resolved the issue and new orders are processing in a timely manner. Thank you for your patience.
Posted about 1 month ago. May 16, 2019 - 21:21 CDT
Investigating
We are investigating an issue creating new Managed WordPress and WooCommerce Hosting accounts/services. Our teams are looking into this and we will update this status once we have some additional information.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted about 1 month ago. May 16, 2019 - 17:28 CDT
This incident affected: Managed WordPress, Managed WooCommerce, and MWP / MWCH Management Portal.