Network Latency
Incident Report for Liquid Web - Services
Resolved
This issue has been resolved.
Posted Oct 22, 2020 - 07:04 CDT
Investigating
We are currently investigating an issue of increased network latency in some cases. We will update this post as we have additional information.

If you have any questions, please contact a member of our support team via live-chat and ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Oct 21, 2020 - 12:30 CDT