Premium Business Email Webmail Disruption
Incident Report for Liquid Web - Services
Resolved
This issue has been confirmed resolved by our teams.
Posted Oct 20, 2020 - 11:38 CDT
Monitoring
A fix has been put in place and we are currently monitoring the situation.
Posted Oct 15, 2020 - 11:26 CDT
Investigating
We are working with our Vendor to identify the issue causing slowness when logging into Webmail for our Premium Business Email Service. Affected Users will experience delays in downloading attachments. In addition, when trying to log into webmail May experience delays or the following error "webmail site may have been misconfigured, please try again" when logging in.
Posted Oct 15, 2020 - 10:57 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 14, 2020 - 13:20 CDT
Investigating
We are working with our Vendor to identify the issue causing slowness when logging into Webmail for our Premium Business Email Service. Affected Users will experience delays in downloading attachments. In addition, when trying to log into webmail May experience delays or the following error "webmail site may have been misconfigured, please try again" when logging in.

If you have any questions, please contact a member of our support team via live-chat and ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Oct 14, 2020 - 11:34 CDT
This incident affected: Business Email.