Premium Business Email Connectivity Issues
Incident Report for Liquid Web - Services
Resolved
Our vendor is reporting the issue resolved. We will continue to monitor and keep communications open with them in case we see any continuing issues.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jul 09, 2018 - 11:29 EDT
Investigating
Our Email Vendor is reporting an issue impacting some users on the Premium Business Email platform. This issue may impact IMAP, POP, and SMTP functionality.

We will update as we gather more information. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jul 09, 2018 - 11:01 EDT
This incident affected: Business Email.