Premium Business Email Webmail Issues
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted 18 days ago. May 29, 2019 - 13:37 CDT
Monitoring
The webmail issue has been resolved but with all the customers still attempting to reconnect to webmail there are some lingering login issues due to the large traffic attempting to connect all at once. As the traffic to the login system begins to balance out any remaining webmail issues should begin to resolve themselves.

We will continue to monitor and work with our vendor and will update with any further information.
Posted 18 days ago. May 29, 2019 - 11:32 CDT
Investigating
We are working with our Email Vendor on an issue that is affecting the Premium Business Email Webmail portal. Webmail for Premium Business Email will experience issues logging in, accessing areas inside of webmail, as well as issues downloading attachments.

We recommend users access their email via a mail client such as Outlook as a workaround. Email delivery is not being impacted at this time.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted 18 days ago. May 29, 2019 - 10:11 CDT
This incident affected: Business Email.