Business Email Control Panel Accessibility
Incident Report for Liquid Web - Services
Resolved
The incident is now closed, normal Control Panel access has been restored.
Posted 4 months ago. Mar 07, 2018 - 05:31 CST
Monitoring
The intermittent issue appears to be resolved, though performance monitoring continues.
Posted 4 months ago. Mar 07, 2018 - 05:11 CST
Investigating
We are currently investigating an issue that is affecting Administrators ability to authenticate to the Premium Business Email control panel.
This is not impacting mailbox access or email delivery.
Posted 4 months ago. Mar 07, 2018 - 04:16 CST