Cart Issues on liquidweb.com
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Apr 05, 2019 - 08:45 EDT
Investigating
We are currently investigating and issue with the liquidweb.com not allowing for new VPS or Dedicated server orders to be added to the cart. These can still be added through manage.liquidweb.com at this time. More information will be provided as it becomes available.
Posted Apr 05, 2019 - 06:21 EDT
This incident affected: Management Portal.