DDOS Attack on cloudhost-323832-us-midwest-1-nxcli-net

Incident Report for Liquid Web - Services

Resolved

Following the mitigation efforts, we are no longer observing any signs of malicious or abnormal traffic, and the server is operating normally.

All services remain stable at this time.

If you have further questions or concerns, please contact us at support@nexcess.net or via Live chat.
Posted Feb 23, 2026 - 14:19 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 22, 2026 - 06:04 EST

Update

We are continuing to investigate this issue.
Posted Feb 22, 2026 - 05:27 EST

Update

We are continuing to investigate this issue.
Posted Feb 22, 2026 - 05:26 EST

Investigating

We have been alerted to a DDoS attack targeting cloudhost-323832-us-midwest-1-nxcli-net. Our network engineers are engaged and we will update with further details regarding mitigation as soon as we are able.

If you have any further questions or concerns, please feel free to reach out to us at support@nexcess.net or call us at 866-639-2377, 313-279-0722 (international).
Posted Feb 22, 2026 - 05:24 EST
This incident affected: Cloud VPS Hosting.