Scheduled Maintenance
Incident Report for Liquid Web - Services
Resolved
This has been resolved.
Posted Jul 01, 2021 - 14:51 CDT
Investigating
On Saturday June 12th, 2021, our Chat, Ticketing and Help Center service will have a short period of maintenance between 1:00 - 1:05 am ET. During this window, customers may see a interruption in service, however customers can contact Liquid Web via phone during this time. This maintenance does not impact customer services, just the ability to reach our support team and Help Center.
We encourage customers to reach out to us via phone at 1-800-580-4985 (1-517-322-0434) if you have any questions or concerns.
Posted Jun 09, 2021 - 10:54 CDT
This incident affected: Support Services (Chat Support, Ticket Support).