Business Email Webmail Issues

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved.
Posted Oct 15, 2024 - 11:58 EDT

Monitoring

Our email vendor has applied a fix, and we are currently monitoring it.
Posted Oct 15, 2024 - 08:05 EDT

Update

We are continuing to investigate this issue.
Posted Oct 14, 2024 - 10:26 EDT

Investigating

Our email vendor is reporting issues with accessing the newly created mailboxes, and we are working with them to resolve this issue. As we have additional info we will provide updates here.

Our teams are here to help you. Please do not hesitate to get help via live-chat, ticket or by toll-free phone at 1.855.348.9060 or internationally at +1.517.322.0434.
Posted Oct 14, 2024 - 10:25 EDT
This incident affected: Business Email.