Liquid Web Management Portal Degraded
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Jan 16, 2025 - 15:32 EST
Monitoring
Our team has implemented changes and customers may see portal experiences return back to normal. We will continue to monitor the portal experience.
Posted Jan 16, 2025 - 14:30 EST
Identified
Our team has identified an issue that is affecting customer portals at Liquid Web. Clients may be experiencing low load times, issues with Live Chat authentication, issues logging into the Cloudsites Portal, and VPN services.

Our team has been engaged and has released a fix for this issue. We will provide more updates as we have them.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jan 16, 2025 - 13:22 EST
This incident affected: API and Management Portal.