Issue deploying new servers within London Data Center

Incident Report for Liquid Web - Services

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2026 - 17:27 EST

Investigating

We are investigating a networking issue that is preventing new server deployments within our London Data Center.
Existing customer servers are not impacted.

Need help? Chat with us or create a ticket via my.liquidweb.com.

We appreciate your patience and understanding as we work to restore this service. Thank you.
Posted Feb 13, 2026 - 16:11 EST