This maintenance window was cancelled for its original time. It has been rescheduled for October 22nd at 11:00 AM EDT. Please follow the new window for further details: https://status.liquidweb.com/incidents/rlh3hy053t4h
Posted Oct 21, 2025 - 14:00 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 21, 2025 - 11:00 EDT
Scheduled
Liquid Web Network Engineers will be performing scheduled maintenance on network infrastructure supporting a subset of customer services in our DC5 Data Center in Amsterdam, NL.
There is a brief (less than 5 minutes) service interruption per server expected during this maintenance window. Beginning October 14th, customers with affected servers will see an additional notice in their customer portal (https://my.liquidweb.com/). Our support team is on standby if you need any help or have questions or concerns. You can connect with us through the following channels: