Premium Business Email Degraded
Incident Report for Liquid Web - Services
Resolved
The issue with removing services from the Premium Business Email product has been resolved.

If you are seeing an issue please do not hesitate to contact us via live-chat in your customer portal (https://my.liquidweb.com/), ticket (support@liquidweb.com), or by phone at 1-800-580-4985, 1-517-322-0434 (international).
Posted May 03, 2023 - 23:55 EDT
Investigating
Our teams are currently investigating an issue preventing provisioning and removal of services with the Premium Business Email product. We will update this status post as more information becomes available.

Our teams are here to help you. Please do not hesitate to contact us via live-chat in your customer portal (https://my.liquidweb.com/), ticket (support@liquidweb.com), or by phone at 1-800-580-4985, 1-517-322-0434 (international).
Posted Apr 28, 2023 - 17:52 EDT