Chat Functionality Impacted
Incident Report for Liquid Web - Services
Resolved
This issue is now resolved. Our LiveChat is functioning as expected at this time.
Posted Nov 17, 2024 - 10:26 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2024 - 09:36 EST
Investigating
Our teams are investigating an issue causing the Chat Functionality on my.liquidweb.com and manage.liquidweb.com. We will update this status post as more information is available.

We sincerely appreciate your understanding and patience as we resolve this issue. Thank you for your continued support.
Posted Nov 17, 2024 - 08:46 EST
This incident affected: Support Services (Chat Support).