Network Service Impact, Subset of Services, DC3

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved.
Posted Jun 24, 2026 - 12:47 EDT

Monitoring

Liquid Web Network Engineers have identified the cause and implemented a fix, network traffic has resumed at this time to affected areas of the data center. We are actively monitoring the environment. We will provide another update as soon as possible this morning with more information.
Posted Jun 24, 2026 - 10:46 EDT

Investigating

We are aware of a network service event affecting a subset of customers in our DC3 Data Center in Lansing, Michigan. Liquid Web Network Engineers are currently engaged and working to restore service as quickly as possible. We will provide another update as soon as possible this morning with more information.
Posted Jun 24, 2026 - 09:57 EDT
This incident affected: Network (LAN Network) and Data Centers (DC3 - LAN).