Issue with the billing system
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Sep 19, 2024 - 10:13 EDT
Update
Our teams have implemented a fix and this issue is now resolved. All Support services are functioning as expected at this time.
Posted Sep 19, 2024 - 10:12 EDT
Investigating
We are currently experiencing issues with our internal billing system, which may delay delivering our usual Heroic Support. Our team is actively working on a resolution.

We sincerely appreciate your understanding and patience as we resolve this issue. Thank you for your continued support.
Posted Sep 19, 2024 - 09:39 EDT
This incident affected: Support Services (Chat Support, Ticket Support, Phone Support).